
MUSIC FROM PHOTOSHOP
by Richard Canedo

Perhaps you’ve seen them on eBay or at swap meets, offered for a few
dollars each. Or maybe you found a box of them in Grandma’s attic—
piano rolls, an all-but-forgotten digital storage medium, preserving the
keystrokes of decades-old solo performances as 88 channels of binary
data. Ever wished you could hear those performances? Surprisingly,
the same program that can restore old photographs can help to restore
old piano performances as well.

As the punched paper deteriorated over the years, many fine perform-
ances were in real danger of being lost forever; but recently, the dedicated
efforts of roll preservationists, who developed hand-built roll scanners
and custom software, have reopened a unique window into our musical
heritage. The data on the rolls can now be converted into midi files
(the standard musical note file format of the computer age) that can
be played on most any computer with QuickTime or Windows Media
Player, or even on a new generation of midi-capable player pianos.
The midi files may also be used to create an audio CD.

Best of all, anyone with a flatbed scanner (no transparency adapter
needed), Photoshop CS or CS2, access to a Windows machine (or a
Mac running Virtual PC, BootCamp, or Parallels Desktop with Windows
98 or later) and a bit of patience can revive a roll performance and let
the whole world hear it for the first time in decades. 

Piano roll facts
With a few rare exceptions, piano roll paper is 111/4 inches (28.55 cm)
wide. Most flatbed scanners are built to accommodate US and ISO
page sizes, giving the wider dimension of both height and width — an
A4/letter size scanner typically has a live area of about 81/2 x 113/4 inches
(21.6 x 29.8 cm). Piano rolls are therefore just narrow enough to be
scanned eight inches at a time (allowing for necessary image overlap)
on an A4/letter scanner. Figure 1 shows part of an assembled roll image
made from 8-inch scan segments.

Piano rolls are fragile! Remember that you will be handling nearly
century-old paper that has been punched full of holes, weakened by
time, and damaged simply by being played back in its day. Player
pianos were vacuum-operated; the roll paper was dragged across a
metal bar with precisely spaced holes exerting constant suction. Often,
the more popular the performance, the more damage the roll has suffered. 

Piano rolls are long. 20 to 30 ft (6 to 9 m) is typical, corresponding
roughly to a two to three minute song (30 to 45 scans on an A4/letter
size scanner); but much longer performances exist. One roll in my posses-
sion, “Hungarian Rhapsodie No. 12,” clocks in at 8 minutes 20 seconds
when played at the recommended tempo (an adjustable speed setting
on player pianos) — over sixty feet long! Such rolls are best sent to the
growing community of roll preservationists who have built motorized
continuous-scanning devices (see resource list at end of this article).
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Figure 1. Part of a piano roll image
assembled in Photoshop CS from
several scans. Note the tempo
indication and roll number at lower
right, scan section marks placed on
adhesive tape along the right edge.
Damage to left edge did not affect
the midi result.

A scanner bed-size piece of Gator
board or foam board with red paper
affixed to one side was used in
place of the scanner lid, hence the
red color of the perforations and
margins; this allows for accurate
magic wand selection of the perfs
at a later step.



Several piano roll formats exist. Refer to the “Supported Piano Roll
Formats” box at right to make sure the RollScan midi converter has a
template that corresponds to your roll type.

Look for the leader. This refers to the first several inches of the roll, cut
to a tapering point where the reinforced “leader tab” usually identifies
the manufacturer (see figure 2). Information about the song is usually
printed on the leader and typically includes manufacturer’s roll number,
song title, composer/lyricist, performer, song copyright year, roll type,
and recommended playing tempo, commonly a number from 60 to
100. With luck, you may also have the original box the roll came in
— look for a label on one box end, which will have at least some of
the same information. 

If the roll is damaged with a missing or illegible leader, all is not lost.
Many rolls have printed lyrics from which a tune title can be deduced.
An internet search of the title may reveal additional information such
as composer and copyright date.

Even the absence of some perforations at the front end is not neces-
sarily fatal, as some rolls often have repeated passages, from which the
missing perforations may be deduced and copy-pasted into place in
Photoshop (see box at end of article, “An Example of Roll Repair”).

Don’t be concerned about missing or damaged roll ends (flanges) or
ragged edges, as long as the damage doesn’t extend into the perforations.
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Figure 2. The piano roll on the left is a good candidate for scanning: it has
only minor damage and a nearly intact leader containing useful information
about the roll. The roll on the right has lost the first several inches of paper,
including the opening notes of the song. Long ago someone “helped” by
cutting a new taper, sacrificing even more notes. Subsequent playing did more
damage. With no leader or box, only the printed lyrics identified the song as
“Beautiful Ohio.” See box at end of article, “An Example of Roll Repair,” for
a method of restoring opening notes.

Supported Piano Roll
Formats
There are dozens of formats of
piano rolls; the more common
varieties are supported by
Warren Trachtman’s RollScan
Converter, but you should check
this list to make sure. A piano
roll’s format, if other than
standard 88-note, is usually
clearly indicated on the leader,
leader tab, or box end label.

58-note uniform
65-note uniform
Standard 88-note (most common)
Ampico
Duo-Art
Duo-Art British
Welte Licensee
Welte T-100
A-roll
G-roll

You may still succeed with a
format not listed, such as the
Recordo roll type, but you may
have to identify and edit out the
expression/accent tracks in
Photoshop before attempting
conversion to midi — otherwise
these tracks may “play” as errant
low or high notes. Keep a version
of the assembled image with all
tracks intact; some of the contacts
listed at the end of this article
have specialized midi conver-
sion software that can handle
roll types not listed above.



Has this roll performance already been scanned? Before doing lots of
flatbed scans and image assembly in Photoshop, you should check the
roll scanner websites listed at the end of the article to see if the work
has already been done. Just finding the same song title shouldn’t dissuade
you; many popular songs were “covered” by several artists, just as they
are today. Check for the same artist, manufacturer, and roll number.

What you’ll need
• A piano roll in fair condition as discussed above, preferably not too

“fat” (long).

• a ruler, black felt-tip pen and low tack transparent tape such as
Scotch™ brand removable tape to mark scanning intervals

• a long table or other long, clean, flat surface

• a flatbed scanner, A4/letter size or larger

• a mailing tube about 12 inches long to serve as a “take-up” spool.
For extra protection, you can attach roll-end flanges made from those
clear plastic discs that protect CD 50-packs (see figure 3).

• a piece of bright red mat board; or gator board or foam board with
bright red paper such as Pantone ® 180C affixed to one side, slightly
larger than the scanner bed area. When used red side down, in place
of a scanner lid, the red color will show through the holes and be
easily selectable with the Magic Wand tool.
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Figure 3. A piece of Gator board or Foamcore, slightly larger than your
scanner’s live area, will serve as the lid (held in place with one hand during
scanning). Many scanner lids have heavy transparency adapters that could
damage piano roll paper. Bright red paper affixed to the gator board will
make the roll perforations appear red on the scans; they will then be easily
selectable with the magic wand tool.

A “take-up” spool is easily made from a 12-inch length of mailing tube and
two plastic protective disks that come with CD 50-packs. A take-up spool
placed on the opposite side of the scanner from the roll is preferable to
letting the scanned portion of the roll accumulate on the floor. See also
Figure 4 at right, a roll repair rig adapted for scanning.

Figure 4. People already involved in
piano roll repair will likely have a
hand-cranked “rig” that can be
easily adapted for scanning. A
flatbed scanner can be mounted on
its surface, and the roll repair rig’s
spool mechanism will make paper
handling much easier.

(Courtesy Terry Smythe)



• Photoshop CS or CS2 (earlier versions won’t support files with the
vertical pixel dimensions an assembled piano roll image requires)

• two free software utilities:

Anthony Robinson’s BMP2CIS.exe available at
http://semitone440.co.uk/rolls/utils/cis2bmp/index.htm

and Warren Trachtman’s rollscan converter, available at
http://www.iammp.org/FileDisplay.pl
click on 2005April27_RollScanConverter_XML.zip.

• a PC with Windows 98, 2000, or XP to run these Windows utilities;
or a Mac using Virtual PC with Windows 98, 2000, or XP (the utili-
ties should also work when running Windows on the new Intel Macs).
The scanning and Photoshop work may of course all be done on
either a PC or a Mac; as with all Photoshop work, the more RAM
and the faster the CPU, the better.

Preparing the roll for scanning
Don’t even think of cutting the roll into letter-size sheets for easy scanning!
Instead, carefully unroll the first few feet of the roll onto the table
surface, printed side up. Along the right edge of the paper, place a
piece of transparent tape just before the start of perforations and mark
on the tape (not the roll paper) as shown (see figure 5). Use the ruler
to place scan tick marks at exactly every eight inches (every sixteen
inches if you have an A3/Ledger scanner). The tape should extend a
bit beyond the roll edge so it can be folded over (for easier positioning
when the roll is face-down on the scanner). I use the marking conven-
tion |01.......01|02.......02|03.......03|04 etc., so each scan shows a
mark at each end with the “inner” numbers for that scan appearing
twice. Make sure the marked tape does not interfere with perforations,
or printed lyrics if it’s a word roll. Since you’ll be making reflective
scans, you’ll have an image of the entire roll, which you can size down
later and scroll along as the midi file plays. As you continue marking,
carefully wind the marked portion onto the mailtube take-up spool.
You may want to use a couple of paperback books to hold down the
curl-prone paper at both ends of the table as you measure and mark. 
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Figure 5. Marking the roll at eight-inch intervals along the right edge. Rather
than writing directly on the roll, use pieces of removable tape with scan tick
marks the full width of the tape. Fold the tape over the roll edge; the tick
mark on the back will assist in positioning the roll face-down on the scanner.

http://www.iammp.org/FileDisplay.pl
http://semitone440.co.uk/rolls/utils/cis2bmp/index.htm


When you reach the end of the roll, you will likely find an odd pattern
of closely-spaced rows of perforations (figure 6) — a “signal” to the
player piano to stop and rewind the roll. There is no need to scan this
portion unless you want a complete visual record of the roll. These
roll-end perfs should not appear on the final 1-bit image for midi conver-
sion, as they may “play” as errant low and high notes.

If the roll is in poor condition, you may want to start scanning backward
from the end of the roll after placing tick marks to avoid subjecting it
to an extra hand-rewinding; but this can get a bit confusing, especially
if you’re sharing the scanning chore with others. If you’re not going to
scan immediately after markup, it’s best to rewind the roll onto its own
spool for storage.

Scan...take-up...scan...take-up...
Let the tedium begin! With the roll paper face-down and  the roll edge
aligned to the scanner edge as straight as possible, make a series of
reflective RGB scans of at least 150 pixels per inch. Roll scanners’
standard is 300 ppi for the final 1-bit image, but an RGB piano roll file
at 150 ppi  will “upsample” cleanly enough when converted to grayscale,
then to bitmap at 300 ppi; and while working in RGB the file size will
be relatively manageable. If your computer has trouble with very large
image files, see box at right for an alternative approach.

Advanced Photoshop users may want to create “actions” to automate
some repetitive scanning and image assembly tasks. See “Automating
tasks” under Photoshop’s Help menu for more information.

Be certain that BOTH marks for a given segment (e.g., 1|2 and 2|3
when scanning segment #2) are showing fully on each scan. Use the
red backboard as a scanner lid for each scan, applying pressure gently,
but firmly, and as evenly as possible (to avoid shadows in the holes).
NOTE: If you want a complete visual record of the roll, scan the leader,
including tab, using the same settings as above. I recommend saving
each scan (rather than assembling “on the fly” and losing lots of work
in a crash, or enduring slow computer performance as the file grows)
as a JPEG with level 8 quality for disk space conservation (you’ll be
making a truly huge file later). Each scan segment file will average about
300-400K in size when saved, and any JPEG artifacts will be far below
the threshold of troublemaking for midi conversion purposes. Save each
scan segment with the name of the song followed by the two-digit scan
segment number (L1 and L2 if leader is scanned, typically two segments
on an A4 scanner): for example, MandalayL1.jpg, MandalayL2.jpg,
Mandalay01.jpg, Mandalay02.jpg and so on.

Use the take-up spool as before, carefully winding after each scan to
advance the roll to the next marked segment. Be sure that both the
original roll and take-up spool can rotate freely on the work surface
on either side of the scanner, but not accidentally roll off onto the floor,
get tangled in computer cables, etc.

When you’ve made the last scan, carefully rewind the roll onto its spindle,
place the roll in its box if it still has one, and store it in a safe place.
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Figure 6. Typical perforations at the
end of a roll. Their original purpose
was to signal a player piano to
rewind the roll. They should not be
included in the assembled scan, as
they will likely play as errant notes
when converted to a midi file.

Long on Ambition,
Short on Horsepower?
If you have an old, slow computer,
an old version of Photoshop, or
both, you can still try your hand
at roll scanning, as long as the
roll is under 25 feet long. I’ve
gotten acceptable midi results
from scans of 100 ppi, keeping
that resolution through the entire
image assembly and conversion
process. Schoolteachers consid-
ering a class project in roll
scanning might try this approach
if their classroom computers can’t
handle large image files.

A 100-ppi assembled image of
a roll under 25 feet long will be
less than 30,000 pixels tall, which
older versions of Photoshop can
handle. It also allows saving the
black-and-white “perf-only” image
as a single BMP file for con-
version to CIS format. Scanning
times will be shorter; the RGB
assembled scan will be under
100 meg; and the 1-bit BMP file
will be 4 meg or less. At this lower
resolution, good track alignment
and a clean selection of the red
perfs in the assembled image is
especially important. Remember
to enter a resolution value of
100 in the BMP2CIS utility and
the midi converter.



Assembling the image
If you have a wide-screen monitor, you may wish to assemble the scans
“sideways”, with perforation tracks running horizontally, and rotate 90°
when the image assembly is done; but you’ll probably find it easier to
build a vertical image, with printed lyrics (if present) oriented normally
(as shown in figure 1).

You may be tempted to use an image “stitching” utility of the type used
to make panoramas from a sequence of photos; but my experience with
these has shown that they have trouble distinguishing one perforation
from another, and often misalign or overshoot the proper join positions.
Also, the composite image size will likely exceed their capability.

It is very helpful to use Photoshop’s Grid feature when aligning the roll
segments. In Preferences>Guides, Grids & Slices, use the grid settings
as shown in figure 7 for a typical roll with 9 tracks per inch; for older
and less common 6-track-per-inch rolls, change the “Gridline every”
value to 2 inches. Use the View>Show>Grid menu command to make
the grid visible. Figure 8 shows a roll scan segment with gridlines. Bold
vertical gridlines are an octave apart.

Open the first scan image and rotate 90° if needed. You will almost
certainly need to apply a bit of numeric rotation to get the tracks vertical:
Command + A, select all (Ctrl+A in Windows); Command + T, transform
(Ctrl+T in Windows), enter tenths of a degree or minus tenths of a degree
in Angle of Rotation field; double-click in the image area to apply.

Next, increase canvas size (Image>Canvas Size) to accommodate the
rest of the scans. If you scanned 8-inch segments and 32 scans total,
you will need to make the canvas height 256 inches. On the “anchor”
diagram in the Canvas Size dialog box, select the bottom-center square.
Note that your 113/4 x 256 inch file, at 150 ppi, will be nearly 200 megs.
See box on page 5, “Long on Ambition, Short on Horsepower?” if you
encounter problems with a file of this size.

Save as a Photoshop (PSD) file, or as a TIFF with LZW compression if
desired to keep file size small. Other file types generally do not support
images over 30,000 pixels tall.
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Figure 7. These grid settings will
assist in aligning roll segments and
keeping tracks vertical.

Figure 8. Each note track falls between vertical gridlines; bold vertical gridlines
are an octave apart.



Keeping this file open, open the next scan segment file and rotate it in
the same way as the first. With the Move tool (access by hitting the V
key), drag the image onto the first file, which automatically creates a
new layer. Close the second segment file without saving changes (the
90° rotation). On the first file, set the new layer’s opacity to about 50%
and align the edge mark to the identical mark on the base layer (see
figure 9). Again, some rotation of the image on the new layer will
probably be necessary: Command + T (Ctrl+T in Windows), enter numeric
value in angle of rotation field, double-click in transform bounding
box on image to apply. Don’t get discouraged if it’s difficult to get a
segment’s tracks absolutely vertical; the midi converter software you’ll
be using has some tracking correction capability. After aligning, reset
the new layer’s opacity to 100%, then flatten layers.

Continue adding segments one at a time, aligning then flattening each
segment. Save often! As note tracks start and stop throughout the song,
you may need to add vertical guides to assist in aligning. One of the
most useful tracks is usually the sustain pedal track near the left edge
of the roll; but not all rolls have them, and the expression rolls mentioned
earlier have additional tracks near both edges. Avoid the temptation to
use the image of the paper edge for aligning, as it may be unevenly
worn, and the perforation tracks may have been a bit out of alignment
to the edge when the roll was manufactured.

After all segments have been added to this file, scroll through to check
alignment, make sure all layers are flattened, and save. You may want
to save a second smaller version of this color image to scroll along
with the music file you’ll be listening to. I’ve found that resizing to
5.625 inches wide (half the actual roll width) and 72 ppi, then saving
as an RGB JPG, quality level 7 or 8, produces a relatively compact file
that is detailed enough to read if it’s a word roll.

Preparing the image file for midi conversion
In the large assembled file, zoom in on one of the red perforations.
Using the magic wand with tolerance of 45 to 50, anti-alias option
checked, and contiguous option UNchecked, select the center of the
perf. The selecting operation may take a while due to the large image
size. All the perfs should be selected, but none of the blemishes, specks,
or printing, as shown in figure 10. (This is why I recommend bright red
as the show-through color—it’s different enough from the paper color
as well as from the often bluish-green printed lyrics, black and brown
specks, etc.) It may be necessary to adjust the tolerance number lower
or higher and retrying the magic wand, but I’ve gotten consistently good
results with a value of 48 when using the Pantone® 180C colored backboard.

Set foreground color to pure black and background color to pure white
(the default foreground and background colors — click on the small
black/white double square to the lower left of the large double square
icon near the bottom of the Photoshop toolbar). Fill the selected perfs
with 100% black (Edit>Fill, foreground color, normal blending mode,
100%). Now choose Select>Inverse to select everything BUT the perfs.
Hit Delete. Your image should now look like figure 11 — solid black
perfs on a solid white background.
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Figure 9. Assembling the roll
segments into a continuous image.

Figure 11. After selecting the red
perforations with the magic wand, fill
the perfs with 100% black; then
invert the selection and clear the
background to white.

Figure 10. The red perforations
selected with the magic wand tool.



Select Image>Mode>Grayscale. If you get the “Discard color informa-
tion?” dialog box, click OK. Then select Image>Mode>Bitmap and set
output ppi to 300. For Method, choose 50% threshold. Next, select
Image>Rotate Canvas>Flip Canvas Vertical. This last step is required
by the midi converter, which “reads” the image from top to bottom,
rather than a physical roll in a player piano which travels in the other
direction across the stationary reader bar. Figure 12 shows an RGB
assembled scan alongside the flipped 1-bit version.

Save the image as a new TIF file. This will be the only file option
available, as only TIF supports 1-bit files greater than 30,000 pixels tall
within Photoshop. If your RGB scan included the tapered leader, crop
it off — it will only confuse the midi converter. Also delete any roll-
end signal perforations discussed earlier, either by cropping off that
section or erasing to white. Next, crop the image’s overall width to the
visible roll edge, as closely as possible; your image should now be
nearly 111/4 inches wide.

If you anticipate sharing your work with other rollscanners, do this
additional step: With background set to black, increase canvas size
width (Image>Canvas Size) to 3648 pixels; leave canvas height as is.
Select the center square for anchoring and click OK. This creates a roll
image centered between black margins, and an overall width of 12.16
inches @300ppi, which is what some midi converter programs require.

For the next step, you’ll have to break the image up into at least two
and probably four parts (Yes, I know you just finished putting them
together!). The midi converter software evolved on the PC side of things,
using a proprietary file format called CIS (after Contact Image Sensor,
the heart of most home-built motorized roll scanners). Photoshop cannot
save directly to CIS format, one of the few that supports dimensions
exceeding 30,000 pixels; fortunately, a free utility exists that can convert
sequential images saved in the venerable Windows BMP image format
to a single CIS file.

Like most image file formats, BMPs cannot exceed 30,000-pixel dimen-
sions in Photoshop. Check total pixel height of the TIF image (Image>Image
Size). If it’s under 60,000, you’ll only need to break it up into two BMP
files. More likely, it will be around 100,000 pixels or more. Here’s how
to divide it into four equal-height files with no overlap or omitted pixels:

Use Command + 0 (Ctrl + 0) in Windows) to fit the entire image on your
screen. Select View>Snap. Drag a guide down from the top ruler slowly,
and it will snap to the exact midpoint of the image. Use the marquee to
select the upper half of the image, snapping the bottom of the selection
to the midpoint guide. Now drag another horizontal guide down slowly,
and it will snap to the midpoint of the selection. Invert the selection,
then do the same for the lower half. Now you have guides at 1/4, 1/2,
and 3/4 of the height of the image. Select the top quarter with the marquee,
making sure you’ve got the full width, and copy-paste into a new file,
flatten layers, then save as a 1-bit Windows BMP. In Save options,
choose Windows, not OS2; 1-bit depth; Flip Row Order unchecked.
Save as (songname)1.bmp; do the same for the remaining quarter-images
to create (songname)2, 3, and 4.bmp.
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Figure 12. An RGB JPEG of the
assembled roll image, with leader,
lyrics, and roll-end perforations; and
the vertically flipped 1-bit (black-
and-white) image of the same roll
with music perforations only, as the
midi converter requires.



Nearly There
In Windows, double-click the BMP2CIS.EXE file to launch (see figure
13). If you’re using Windows with Virtual PC on a Mac, you’ll need to
drag the BMP image files into a folder on the Virtual C drive; BMP2CIS
will generate a CIS file in the same folder, but cannot use a folder on
the Mac desktop.

Enter a name for the CIS file (no need to type the “.CIS” extension).
Enter the name of the song in the Roll Title field. Enter the Tempo
number, typically 60 to 100, which should be printed on the roll leader.
If the leader is missing or the tempo is unreadable, enter 80; you can
change it later if the resulting midi sounds unnaturally fast or slow.
Enter 300 for Horiz DPI and Vert DPI. “Single Array” should be selected.
Since you inverted the image in Photoshop, do not check “Vertical
Invert.” “Negative” should also be unchecked. Launch Windows Explorer
and open the folder containing the BMPs. Drag (Songname)01.BMP
into the BMP2CIS window; you’ll see a CIS file created in the same
folder. Next, click the “File Append” checkbox at lower left in the
BMP2CIS window. Drag the remaining BMPs, one at a time, in correct
order. Note the CIS file size increasing with each appended BMP. Close
BMP2CIS after dragging in the last BMP.

Make the midi
Still in Windows, launch the rollscan converter by double-clicking the
2005April27_RollScanConverter_XML.exe file. Open the CIS file with
the File>Open... menu command. A dialog box will appear (figure 14)
in which you can enter known information about the roll. Click OK
when done; you can access this dialog box again if needed by clicking
the View/Set Embedded Text button.
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Figure 13. The BMP2CIS Converter
dialog box.

Figure 14. The RollScan Midi Converter dialog box for embedding roll info.



In the “Roll Type” drop-down menu, select the type of roll if known
(figure 15). “Fail-Safe” sounds promising, but it lacks the ability to use
the sustain pedal track that most rolls have; “Generic_Uniform” is usually
the best choice for a standard 88-note roll. If your roll has extra “expres-
sion” tracks near both edges (figure 16), select the roll type that matches
the expression or reproducing roll manufacturer, such as Ampico or
Duo-Art. If the roll has expression tracks, but you can’t identify the
type, try to match it to one of the templates in the converter; if no
match can be found, see the “Supported Piano Roll Formats” box earlier
in this article for a possible solution.

The sustain pedal track just mentioned is the one closest to the left edge
on a standard 88-note roll. Click on the Scanner Settings button to enter
an offset number (figure 17) and adjust the value until the sustain track
falls in the pink stripe on the left side of the converter. The PPI value
should be 300, matching the PPI of the final 1-bit Photoshop image.
Other values should be as shown. In most cases, roll “stretch” should
not be a problem, so leave this setting at 1 unless tracks are not coming
close to lining up in the stripes. They don’t need to fall exactly in the
stripes at this stage; you’ll be using an Active Tracking feature a bit later.
The ScanMIDI box should be checked; the eRollMIDI box should be
unchecked unless you want to simultaneously create a special type of
midi file used by certain electronic player pianos.

In the menu bar, select Settings>ScanImageMIDI settings — the dialog
box that comes up is called General Settings (figure 18). Enter values
as shown; the “merge holes” option prevents rolls with the dot-chain
perforation style from playing as a bizarre torrent of 64th notes. If the
midi result sounds like musical machine gun fire, try a higher value,
but always under a tenth of an inch.
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Figure 15. The RollScan Converter
roll type list.

Figure 16. A piano roll with
expression tracks near the edges.

Figure 17. Using “Horiz Offset” to move the sustain pedal
track into correct position (pink stripe). This usually gets
other tracks close enough to their correct position for the
converter program’s “Active Tracking” to work properly.

Figure 18. RollScan Converter general settings.



Clicking the CIS Data button brings up a dialog box (Figure 19) in which
you can change the tempo and other attributes that were entered when
the CIS file was created; useful if you need to experiment with tempo,
but otherwise editing these values will probably not be necessary.

Click on Re-Process in the main window after making any changes.
Checking the Show Tracking Corrections box will let you see how the
converter has snapped the perforation images into the key tracks. The
converter has automatically made a .mid file in the same folder as the
.cis, and will overwrite it when you click Re-Process.

That’s it! You can listen to the midi file with QuickTime, iTunes, or Windows
Media Player. Don’t be discouraged if your early results don’t sound right;
most common problems are easily fixed by adjusting settings in the midi
converter. Problems such as abrupt changes in key or unnatural gaps
or skips in the song are usually the result of inaccurate positioning of
scan segments when assembling the image in Photoshop. Often these
problems can be found and fixed by examining the BMP files in Photoshop,
requiring only the BMP to CIS and midi converter steps to be repeated.

Sharing Your Results
If you’re pleased with your piano roll midi file, I encourage you to
share it with the world through any of the websites listed at the end of
this article. The resource list includes some very dedicated individuals
and organizations. They will likely be interested in the CIS file as well
as the midi; a CIS file can be used to create special midi types for
modern electronic player pianos, and even to recut new rolls for the
pneumatic player pianos still out there!
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An Example of Roll Repair
Many piano rolls have suffered severe damage over the
years, mostly in the first few feet. When the damage
extends into the start of perforations, you will of course
have an incomplete performance; but if the song has a
typical structure, with verses repeated, you may be able
to salvage it with a simple copy-paste. The figure at right
shows a section of “Beautiful Ohio” (artist and roll
manufacturer unknown due to leader damage).

The black perfs are the surviving opening notes; the yellow
area represents missing or severely damaged paper. The
gray perfs are copied from the start of the second verse,
offset in this illustration to show a nearly 100 percent
correlation. It was common for piano roll makers to
mechanically duplicate passages, a dubbing trick similar
to recording studio techniques used today. By aligning
a copy of the intact second verse section over the
corresponding first verse, I was able to create a complete-
sounding performance.

Figure 19. The RollScan Converter’s
CIS Data dialog box.



Resource List
Player Piano Rebirth
http://members.shaw.ca/smythe/rebirth.htm

Terry Smythe’s Archive of Preserved Piano Rolls in Midi Form
http://members.shaw.ca/smythe/archive.htm

Download Anthony Robinson’s BMP2CIS utility and related
software at
http://members.shaw.ca/terry122/software.htm

Warren Trachtman’s Roll Listing
http://www.trachtman.org/rollscans/RollListing.php

Download Warren Trachtman’s RollScan Converter software at
http://www.iammp.org/FileDisplay.pl

click on:
2005April27_RollScanConverter_XML.zip

The International Association of Mechanical Music Preservationists
http://www.iammp.org

Robert Perry’s Roll Listing
http://www.pianola.co.nz

Automatic Musical Instruments Collectors’ Association
http://www.amica.org
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Terry Smythe
Note
Richard Canedo can be reached at:

<rcanedo@gia.edu>


